4.3 View dashboards .......................................................... 133
4.3.1 Overview .............................................................. 134
4.3.2 Case Inspector ....................................................... 135
4.3.3 Activities .............................................................. 136
4.3.4 Resources ............................................................. 136
4.4 Create dashboards ...................................................... 137
4.4.1 Create from existing views .................................... 138
4.4.2 Create from scratch .............................................. 140
4.4.3 Add Stat Tiles ....................................................... 141
4.4.4 Add charts .......................................................... 144
4.4.5 Add Tables ........................................................ 145
4.5 Add charts to dashboard ............................................. 146
4.5.1 Activity instances over time chart ......................... 147
4.5.2 Active cases over time chart .................................. 148
4.5.3 Case variants chart .............................................. 148
4.5.4 Activity instances per case chart ......................... 149
4.5.5 Case duration chart ............................................. 149
4.5.6 Case Utilization ................................................... 150
4.5.7 Processing time chart .......................................... 150
4.5.8 Waiting time chart .............................................. 151
4.6 Save dashboard ........................................................ 152
4.6.1 Save a dashboard ................................................ 152
4.6.2 Open a saved dashboard ...................................... 154
4.7 Additional dashboard functionality .............................. 156
4.7.1 Advanced View – Slice & Filter ............................. 156
4.7.2 Advanced > Slice .................................................. 156
4.7.3 Advanced > Filter .................................................. 159
4.7.4 Add Reference Lines .......................................... 161
4.7.5 Add KPI ............................................................. 162
4.7.6 Compare Multiple Process Variants ....................... 163
4.7.7 Split Charts ........................................................ 164
4.7.8 Zoom-in/Zoom-out ............................................. 165
4.7.9 Add filter ............................................................ 166
4.7.10 Export/Download Chart ...................................... 167
4.7.11 Clone Chart ........................................................ 168
4.7.12 Organize Charts .................................................. 168
4.7.13 Remove Chart(Tile/Table ................................... 169
4.7.14 Copy Format ....................................................... 169
4.7.15 Copy Settings ....................................................... 170
4.7.16 Edit Dashboard .................................................... 171
4.7.17 Download Dashboard .......................................... 171
4.7.18 Set Dashboard as “Home” .................................... 171
4.7.19 Change style of dashboard ................................. 173
4.7.20 Change Scale ...................................................... 174
4.7.21 Reset Views ......................................................... 174
4.8 Simulate process ........................................................ 175
4.8.1 Specification of simulation parameters .................... 176
4.8.2 General parameters tab ...................................... 178
4.8.3 Timetables, Resources and Tasks parameters tabs .... 181
4.8.4 Gateways .......................................................... 186
5 Redesign ................................................................. 193
5.1 Search similar models .............................................. 193
5.2 Merge models ........................................................ 194
6 Monitor

6.1 Train predictive models ............................................................... 197
6.2 Open predictive dashboard ............................................................ 199
   6.2.1 Export performance predictions into CSV ................................. 202

7 Release Notes .............................................................................. 203

7.1 Version 8.0 .................................................................................... 203
   7.1.1 Feature/Enhancement ................................................................. 203
   7.1.2 Improvements and Bug Fixes ...................................................... 204

7.2 Version 7.20 ................................................................................. 205
   7.2.1 Feature/Enhancement ................................................................. 205
   7.2.2 Improvements and Bug Fixes ...................................................... 206

7.3 Version 7.19 .................................................................................. 206
   7.3.1 Feature/Enhancement ................................................................. 206

7.4 Version 7.18 .................................................................................. 207
   7.4.1 Feature/Enhancement ................................................................. 207
   7.4.2 Bug Fix ................................................................................... 209

7.5 Version 7.16 .................................................................................. 209
7.6 Version 7.15 .................................................................................. 210
7.7 Version 7.14 .................................................................................. 210
7.8 Version 7.13 .................................................................................. 210
7.9 Version 7.10 .................................................................................. 211
7.10 Version 7.8 ................................................................................... 212
7.11 Version 7.6 ................................................................................... 212
7.12 Version 7.5 ................................................................................... 212
Apromore is a leading provider of open-source solutions for process mining and AI-driven business process improvement. Our vision is to democratize process mining by enabling organizations to achieve digital transparency and operational excellence.

1.1 Apromore Portal

The Apromore Portal is the first and primary interface that users access. One can navigate the workspace folders and perform various actions through the available plugins.

The Apromore workspace containing files and folders appears after successfully logging in. Different icons represent a process model and log. To select a file, click on it. To add a new file, click on Upload. To save a file, click on Download.
Note: We can also select the *Upload* and *Download* options from the File menu drop-down.
We can select and unselect all files simultaneously by clicking on Select/Unselect buttons for ease of access. To search a file, use the Search bar.

To remove the selected file/folder from the workspace, click on Cut while to create a duplicate, click on Copy. To paste the file/folder in the desired directory, click on the Paste button. To rename or delete a file/folder – select it and click on Rename or Delete.

To add a new folder to the workspace, click on the Create folder button. The created folder appears on the My Workspace panel.
To open the log – double-click on the file, and by default, it opens in the process discover plugin.

1.2 Process discoverer

When first opened, the Process Discoverer displays a process map of the event log. By default, each node in the process map represents an activity. Each arc represents a directly-follows relation between two activities. We can tune the number of nodes and arcs in the process map using the Abstraction sliders. To change the percentage of visible nodes, use the nodes slider. When the nodes slider is set to 100%, the Process Discoverer displays all the nodes. When the nodes slider is 0%, we only see one node. Similarly, when the Arcs slider is set to 100%, we can see all the arcs, and if we set it to 0%, we see a minimal number of arcs, in such a way that all the selected nodes are displayed, and every node is on a path from the start node to the end node of the process map. When we move the Abstraction sliders from right to left, Apromore gradually removes elements starting from the least frequent one to the most frequent one. By clicking on the Invert Ordering, we can ask Apromore to do the opposite. This means that as we move a slider from right to left, Apromore will remove the most frequent elements and keep the less frequent ones. If we select the Average duration option in the Abstract drop-down menu, Apromore will remove nodes and arcs based on their duration (instead of their case frequency).

If we wish to observe the branching points, rework loops, and parallel activities in the process, it is better to switch to the BPMN view. When we switch to the BPMN view, Apromore tries to discover parallel relations between activities. We can ask Apromore to find less parallelism or more parallelism by using the Parallelism slider. When the Parallelism slider is at 0%, Apromore will not display any parallel gateway. When it is set to 100%, Apromore tries to discover as much parallelism as possible, given the selected level of arcs abstraction. By default, the Process Discoverer displays the case frequency of each activity and each arc. We can change the statistics overlaid on top of each activity or arc by using the drop-down menus in the Overlay section of the Process Discoverer.
We can save the finished file in a BPMN format or as a filtered log after applying different filters. To see both tasks and gateways and explore decision points, switch to BPMN mode.

Use the Log statistics panel to check the Case variants, the Events, and Activities one by one.
For convenience, there is also a possibility to change the layout or fit the model.

### 1.3 Filter

An alternative way to select a subset of cases or processes and retain specific cases is to use Filter.

To filter logs, click on the Filter.
1.4 Dashboards

To open the dashboard, go back to the Portal, select at least one event log and select the View performance dashboard option from the Analyze menu drop-down.

**Note:** Select multiple event logs to compare them in the dashboard.

To create a dashboard from an existing dashboard or create a dashboard from scratch, click on the ‘+’ button. To download the current view of the dashboard, click on the Download report button.
To customize view of the dashboard, click on the *Change style* button and select from different styling options. We can choose to reset view of the dashboard by clicking on the *Reset view* button.

**Note:** We can choose to reset the current view or all the views.

To auto-save a file, click on the *Save dashboard* button.

To enlarge the specific area - click on the chart and select the area. As soon as you release the mouse, the tool zooms into the selected part of the chart. To zoom out and see the entire chart again, click on *Reset Zoom*. 
1.5 Process Animation

To trigger log animation from the Portal, select at least one event log and a process model and click on the *Animate logs* from the *Analyze* menu drop-down.

Each case is captured by one token and is displayed on the process map/BPMN model. A bottleneck can be identified depending on how the different tokens traverse process map/BPMN model.
Note: If the token goes around an activity’s border, this indicates that the particular activity is skipped in that process case.

1.6 Administration

To manage the item’s access right, select a folder, event log, or model in the Portal and click *Share file or folder*.

Select the user and assign the desired permission. Click on *Apply Changes* to save the changes.
1.6. Administration
2.1 Navigating the Apromore Portal

The Apromore Portal is the first and primary interface that users access. One can navigate the workspace folders and perform various actions through the available plugins. This introduction covers the basics of the Apromore Portal.

Please refer to the various entries in the user guide for specific plugins information and capability.

To view the Apromore portal, log in using valid credentials.

The Apromore Portal appears after successfully logging in. The workspace folder structure/folders tree is on the left-hand side of the portal window in the My workspace area. We can expand/collapse individual folders by using the arrow icon next to each folder. We can also expand/collapse all folders at once using the two icons located on the top-right of the folders tree.
The central area of the portal contains the file view. The file view shows folders, process models (represented by a flowchart icon), and event logs (represented by a logbook icon). We can view the files either in grid or list format.
We can see the details such as version, last update time, and owner of a process model in the *Details* view.

**Note:** The *Details* view is populated only when a process model is selected.

We can double-click on a process model to edit it using the BPMN 2.0 standard in the *Apromore Editor*. Likewise, we can also double-click on an event log to reverse-engineer the process map or BPMN model from the selected log in the *Process Discoverer*.
2.1.1 File Menu

The File menu is used to manipulate files, such as uploading or downloading models and logs, creating a new folder or process model, renaming a file, and deleting it. The other menus (Discover, Analyze, Redesign) provide access to the various process mining and process model manipulation plugins.

We can access the user guide from the question mark button on the top-right corner of the Portal.

The File menu functionality is also easily accessible from the top buttons bar.
2.1.2 Share file/folder

To share an individual file/folder, select the file and click on the *Share file or folder* button.

![Image of file sharing](image)

2.1.3 Access Rights

To view a comprehensive list of all the files and folders along with the users and access rights, click on the *Manage Access Rights* button.

![Image of access rights](image)

**Note:** Only a user with administrator rights can access the *Access Rights Management* functionality.
2.1.4 Manage users and groups

To manage different users and groups, click on the **Manage users and groups** button.

Note: Only a user with administrator rights can access the **Manage users and groups** functionality.

2.1.5 Rename File

To rename a file, select a file and click on **File > Rename**.

Enter a file name and click **OK**.
Tip: As an alternative, we can click on \[\text{הט} \] to rename a file/folder

2.1.6 Delete File/Folder

To delete a file/folder, select a file and click on \textit{File > Delete}.

Note: If a process model has multiple versions, the model with the latest version is deleted
2.1.7 Cut/Copy/Paste files

To copy a log/model, select it and click on the *Copy* button.

Paste the log/model in the desired directory by clicking on the *Paste* button.

To move a log/model, select it and click on the *Cut* button and then paste the log/model to the desired directory.
2.1.8 Search File/Folder

We can search for specific folders or files by entering keywords in the textbox. The results appear in the file view.
2.1.9 User Menu

To check Apromore’s version number and the list of available plugins, change the password and sign-out, click on the user menu.

To report a bug or any other problem related to Apromore, select Report Issue from the user menu drop-down.

Note: If possible, please mention the steps you performed that led to the issue and also attach the related logs so that the Apromore team can quickly and effectively address the issue.
2.2 Upload a file

We can upload both process models in BPMN and event logs in CSV, XES, MXML, XLSX, and Parquet formats.
We can do it through two options – *Upload Local File* and *Upload File from a URL*.

**Note:** The plugin supports the following delimiters: Tab, Semicolon, Comma, and Spaces. However, the plugin supports comma delimiter the most.

### 2.2.1 Upload a Process Model

To begin uploading a file, click on *File -> Upload*.

**Tip:** As an alternative, we can click on ![upload icon] to upload a file/folder.

To browse for the .bpmn file, click *Browse* and locate the file.
We can upload both process models in BPMN and event logs in CSV, XES, MXML, XLSX, and Parquet formats. A window will open, displaying a file selection. Here we can select the relevant file, and it will appear beside the “Browse”. Click OK to upload the file.

Finally, the successfully uploaded file will be placed into the location/repository in which we have initiated the plugin.
2.2.2 Upload an Event Log

Apromore allows us to import event logs in Comma-Separated Value (CSV) format, standard XES format and in MXML format. Event logs can be uploaded uncompressed or compressed (zip or gz). The supported file extensions are .csv, .csv.zip, .xlsx, .xes, .xes.zip, .xes.gz, .mxml, .mxml.gz, .parquet.

Files in XES format are imported directly, as they already contain all the metadata required by Apromore.

On the other hand, we need to pre-process CSV files before import into the Apromore workspace.

To begin uploading a file, click on File -> Upload.

Note: As an alternative, we can click on icon.
To browse for the CSV file, click *Browse* and locate the file.

**Note:** The plugin supports the following delimiters: Tab, Semicolon, Comma, and Spaces. However, the plugin supports comma delimiter the most.

After we insert the link, click *OK* to finalize the uploading process.

A window will open up, displaying the data based on the imported CSV file.

In this pop up window, we can tag each column in the CSV file with one of the following column types: case identifier, activity, start timestamp, end timestamp, other timestamps, resource, case attribute, event attribute, or ignore (in the latter case, some columns are dropped, but we can see them at the columns drop-down menu).

To upload a CSV file, we must indicate which column corresponds to the *case identifier*, which column corresponds to the *activity*, and the *end timestamp*. These three columns are mandatory. We may also tag other columns.
For example, a case attribute is a column whose value is the same for every event of a case. For example, an attribute “Customer Gender” is likely to be a case attribute since it does not change during the execution of a case.

An event attribute is an attribute that changes during the execution of a case, e.g. the “Offered Loan Amount” is likely to change: at the beginning it has an empty value and then it gets a value in the middle of the execution of a case.

Additionally, the CSV importer supports a wide range of encoding options. We can change the encoding by merely clicking on the Encoding drop-down menu.

By default, the time zone is automatically detected. To change it, select the desired time zone from the TimeZone drop-down.
The CSV importer can sometimes automatically tag the columns corresponding to the case identifier and activity. It is important, however, to check that the columns have been tagged correctly. We can manually alter the column attribute by clicking the drop-down menu as shown below and choosing the desired attribute.

The timestamp is automatically detected. To change it, click on the *Specify timestamp format* button.
We can opt not to import a column by attaching the *Ignore* tag to it. To make it easier to ignore multiple columns, we can click on the *Event attribute* -> *Ignore* button at the bottom-left corner. From that point on, any column we select becomes tagged with *Ignore*.

Similarly, if we need to tag multiple columns as *Event attribute*, we can click on *Ignore* -> *Event Attribute* in the bottom-left corner. From that point on, any column we select becomes tagged with *Event Attribute*.
After the columns have been tagged, click *Upload Log* to finish the import.

A dialog box will appear with a message about the total number of events process and if the file has been imported successfully. Click *OK* to complete the import.
The successfully imported log will be placed in the current folder in the Apromore workspace. Apromore internally stores files in XES format.

**Note:** After we upload a CSV file, the schema mapping is stored in system. So next time when we try to upload a CSV file with the same header (both header names and order), the importer will prompt a dialog to let us choose whether to apply the saved mapping.
2.2.3 Upload a file from URL

This feature allows us to upload a file from Dropbox, Google Drive, and Microsoft OneDrive. To upload a file from a URL, click on File -> Upload.

Note: As an alternative, we can click on icon.

Switch to the “Upload file from URL” tab.
Note: The supported file formats are bpmn, csv, xlsx, mxml, mxml.gz, xes, xes.gz, zip and parquet.

2.2.4 Upload from Microsoft OneDrive

In Microsoft OneDrive, right-click on the file we want to upload and click on Embed.

Once the Embed drawer opens, click on the Generate button to generate the URL of the file.
Once the link is generated, copy the link contained in the inverted commas (" ") of the iframe src parameter in the embed code snippet.

Paste the link to the File to upload input box and click on Select.
Once we click on Select, the file name will be displayed as highlighted below. Click on OK to upload the file.

The log will be successfully uploaded in the Apromore workspace.
2.2.5 Upload from Google Drive

To upload a file from Google Drive, right-click on the file we want to upload and click on Share.

Once the share window opens up, click on the Change button in the Get Link section to change the file-sharing permissions.

Note: Make sure the file’s visibility is set to Anyone with the link.
Once the sharing permissions are set, click on the *Copy link* button to copy the URL of the file.

Paste the link to “File to upload” input box and click on *Select*. 
Once you click on Select, the file name will be displayed as highlighted below. Click on OK to upload the file.

The log will be successfully uploaded in the Apromore workspace.
Note: Similarly, to upload a file from Dropbox, make sure the file’s visibility is set to *Anyone with the link*.

Paste the link to the *File to Upload* input box under the *Upload file from URL* tab to upload the file in Apromore successfully.

### 2.3 Create data pipeline

The Create data pipeline plugin, also referred as the ETL plugin, allows users to compose event logs from one or more tables or data sources. It aims to integrate data from multiple sources by extracting, transforming, and loading to gain essential business insights for competitive advantage. To define a data pipeline, click on *Create data pipeline* button.

*Note:* We can also select the *Create data pipeline* option from the *File* menu drop-down.
2.3.1 Extract data

We can extract data through two options – *Local File System* and *DB Connections*. The corresponding buttons are placed in the left pane right under the *Extract view*.

*Note:* We can extract tables from relational databases and upload files in CSV and Parquet formats from the local system.
To upload a file from the personal computer, click on the icon in the right corner of the **Local File System**.

To begin uploading a file from the database, click on the “+” icon in the right corner of the **DB Connections**.
When *Add New Database Connection* window appears, insert all the details, choose the suitable options from the *Database Type* and *Connection Type* drop-downs and click on *Connect*.

To delete a file, click on the *Trash bin* right next to it.
When at least 2 logs are uploaded, merge them by selecting the relevant join type from the **Join Type** drop-down menu and appropriate keys.

Fig. 1: INNER JOIN - Returns records that have matching values in both tables; FULL JOIN - Returns all records when there is a match in either left or right table; LEFT JOIN - Returns all records from the left table, and the matched records from the right table; RIGHT JOIN - Returns all records from the right table, and the matched records from the left table;

After all the files are uploaded, table keys and the join type are chosen, click on **Submit**.

2.3. Create data pipeline
2.3.2 Transform data

There are 2 main areas in the Transform view - the list of tables containing all the columns from the extracted logs (marked blue) and the transformed table (marked red).

Note: To complete transformation, we must select at least three compulsory columns: case id, activity, and timestamp.
To add the column from the list to the transformed table, click on the “+” button next to the column name.

**Note:** In the case of large logs, the addition of columns might take some time. Do not click on the same column several times to prevent column duplicates in the transformed table.

To add the whole extracted table to the Transformed table, click the “+” button next to the table name. The tables are marked as 📊.
To rename the column, click on the pencil icon right next to the column name.

**Warning:** Spaces in the column name aren’t supported.

To delete the column from the Transformation table, click on the red “X” button next to Rename.
Note: If the column was deleted by mistake or becomes necessary, we can easily add it to the table again from the columns list.

To add a customized column that is not present in any of the tables, click on + New column button placed in the upper right corner beneath Manage data pipelines button.
After a new column window appears, enter the new column name and click *Create*.

To check or change the values of the column, click *Edit rules* right beneath the name of the necessary column.
Edit rules window appears. The default rule is displayed. In addition to different join operations, we can create columns in the event log by composing existing columns using arithmetic, concatenation, and find-and-replace operations. For example, you can add a `Cost` column to an event log and compute this cost based on the hourly rate of your resources and the duration of tasks.

We can add a new rule by clicking `+ Add new rule`.  

2.3. Create data pipeline
To apply the rule, after the condition is set, click on **OK**.
2.3.3 Load data

When we click on Load view, the transformed log is displayed.

Click on Detect to automatically detect encoding option.

We can opt not to import a column by attaching the *Ignore* tag to it. To make it easier to ignore multiple columns, we can click on the *Event attribute -> Ignore button* at the upper-left corner. From that point on, any column we select becomes tagged with *Ignore*.
Similarly, if we need to tag multiple columns as Event attribute, we can click on Ignore –> Event Attribute in the upper-left corner next to Event attribute -> Ignore. From that point on, any column we select becomes tagged with Event Attribute.

Click on Upload Log to finish the import.
The **Save Log As** dialog box appears. Enter the log name and choose the destination folder from the drop-down. Click on **Upload** to successfully import the log into Apromore.
2.4 Schedule/Manage Data Pipeline

Create data pipeline allows to update logs automatically by scheduling. After scheduling a pipeline, the logs will be fetched directly from the database and transformed according to the set transformation.

We can also manage the scheduled pipelines.

2.4.1 Schedule pipeline

To schedule pipeline, go to the Load view and click on the Schedule pipeline button placed in the right corner under the Manage Data Pipelines button.

The Schedule Data pipeline window appears.

We can choose the frequency of the updates – hourly, daily, weekly, or monthly to extract, transform, and load event logs into Apromore.
To run pipeline instantly, tick the box *Run pipeline now in addition to the scheduled time* placed right beneath the frequency settings.

When frequency settings are complete, choose the *Log name* and *Log destination* and click on *Schedule*. 
2.4.2 Manage pipeline

To check or edit scheduled pipelines, click on *Manage Data Pipelines* button placed in the right corner under the user’s details.

The *Data pipeline Management* window appears, displaying all the scheduling-related details next to the pipeline name: time/frequency of loads, status, last run.
Note: By default, the window shows all the pipelines. To see only Running or Paused ones, click on the corresponding section.

We can pause or unpause the pipeline by moving the pipeline activation slider next to the pipeline name.
To view the details of all the updates of the scheduled pipeline, click on 📊

**Note:** The status of the pipeline run might be either success or fail, where fail means that for some reason the system wouldn’t be able to run the scheduled pipeline successfully.

To delete the scheduled pipeline, click on 🗑️
To run pipeline now, click on ▶️

To close the Data Pipeline Management window, click on the “X” button in the upper right corner of the window.
To refresh the window, click on 

![Refresh icon]
2.5 Create/edit process model

The editor allows one to edit, save, and export (BPMN) process models. To access the editor, double click on the process model you want to edit in the repository browser. The image below shows a snapshot of the editor environment. On the left, the palette containing the BPMN elements. To add any of these elements to the process model, drag-and-drop it on the desired location.

![BPMN Editor Environment](image)

2.5.1 Save model

At the top of the editor, a menu shows the icons of the essential functionalities provided within the editor. The first icon starting from the left, allows us to save the model.

![Save Model Icon](image)

When selected this option, the following message-box appears.
We can choose the version number of the process and the branch (folder) to save it. Each process version is kept in the memory, and it is possible to retrieve any of it at any time (more details on how to access the older versions of a process model come below).

### 2.5.2 Save a copy of a model

If we want to save a copy of the process model, we can click on the menu’s second icon, as shown below.

Save a copy allows us to duplicate the process model in the repository, rename it, and restart the version counter from 1.0.

### 2.5.3 Export model

The third icon exports the process model in the format .SVG. The fourth and fifth icons export the process model in the formats BPMN and PDF (respectively), as pictured below.

Export as .SVG .BPMN PDF

**Note:** Remember to allow pop-up windows before exporting the process, otherwise, the export may fail.
2.5.4 Undo/Redo

The next two icons allow to undo and redo changes applied to the process model.

```
Undo the last action | Redo the last undone action
```

2.5.5 Zoom-in/Zoom-out

Finally, the two zoom lenses allow to zoom-in and zoom-out.

```
Zoom in | Zoom out
```

2.5.6 Access an older version of a process model

To access older versions of a process model, select the process model in the repository browser. Please select the version we want to edit from the tab on the left bottom corner (as highlighted in the screenshot), and either double-click on it or hit the File -> Edit Model.
2.6 Create new folder

Folders help to organize the files for better management.

To create a folder, browse to the directory you want to create a folder and click on File -> Create folder.

Enter the folder name in the window displayed. Click OK.

The folder will be placed into the location/repository in which the user had initiated the plugin.
2.7 Sharing and Access Rights

Apromore allows us to share files/folders. Each file/folder has a particular security level.

Note: By default, each file/folder is created and saved as private and can be accessed, edited, deleted only by the owner.

It is possible to change a file/folder’s security level by selecting it in the workspace and clicking the button.

2.7.1 Share an event log

To share an event log, select the log from the workspace and click on the button.
File Sharing window consists of two sections: List of Users and Associated artifacts.

**Note:** To share all the artifacts (filters/dashboards) associated with a log, set the Viewer (full) permission to the user. To share only specific artifacts (filters/dashboards) associated with a log, set the Viewer (restricted) permission to the user and tick the boxes next to the artifacts to be shared.

We can find a user or group with whom we want to share the file using the Type in a user or group name textbox. Click on Share.
The selected user appears in the users’ list.

We can see the list of associated artifacts automatically shared with a user in the Associated Artifacts section.

**Note:** Only an owner or editor can edit/rename/delete the associated artifacts.
To change the access rights for a particular user, click on the *Permission* drop-down list and select the desired permissions.

Finally, click on *Apply Changes*. 
To revoke access for a particular user, click on the button.
2.7.2 Share a process model

To share a process model, select it from the workspace and click on the share button.

We can find a user or group with whom we want to share the model using the Type in a user or group name textbox. Click on Share.

The selected user appears in the users’ list.
To change the access rights for a particular user, click on the Permission drop-down list and select the desired permissions.

Finally, click on Apply Changes.
To revoke access for a particular user, click on the **button.
2.7.3 Share a folder

To share a folder, select the folder from the workspace and click on the button.

We can find a user or group with whom we want to share the folder using the *Type in a user or group name* textbox. Click on *Share*.

The selected user appears in the users’ list.
To change the access rights for a particular user, click on the Permission drop-down list and select the desired permissions.

Finally, click on Apply Changes.
To revoke access for a particular user, click on the delete button.

**Note:** For security reasons, the files in the folder are not automatically shared. To share a file within a folder, we must select it individually and provide access.
2.7.4 Access Rights Management

Access Rights Management functionality provides the administrators with a comprehensive view of all the files and folders along with the users and their access rights. The administrator can easily browse through the permissions of the files/folders.

**Note:** Only a user with administrator rights can access the *Access Rights Management* functionality.

To share files/folders, click on the button.

After the *Access rights management* window opens, select the file/folder to be shared and enter the username you intend to share the file/folder with in the *Type in a user or group name* textbox.

Click on *Share* to share the file/folder.

On clicking *Share*, the user appears in the users list.
To change the access rights for a particular user, click on the *Permission* drop-down list and select the desired permissions.

Finally, click on *Apply Changes*. 
To revoke access for a particular user, click on the button.

2.8 Manage users and groups

Users and groups management functionality allows us to grant permissions to users for either using features or different artifacts. Each user can belong to a group or can be associated with a role. A Role is an attribute of the user. A Group is a set of users and is about access rights to different folders/files (e.g. as a member of the group Sales I can only access files related to the Sales Department).

Note: Only a user with administrator rights can access the Manage users and groups functionality

Click on the Manage users and groups button.
Once the User and group management dialog opens up, we can create/remove a user, create/remove a group and assign users different roles and groups.

2.8.1 Create new user

To create a new user, click on the create new user button.

Enter all the details in the Create new user dialog and click on “Create” button.
The user will be created.

### 2.8.2 Remove User

To delete a user, select the user you want to delete and click on *Remove user* button.
Click on **OK** to delete the user.

In case we don’t want to lose files that the user had in his workspace we can transfer them to another user. To do so, select the user we want to delete and click on **Remove user** button.
To transfer files, choose *Transfer ownership option* in the bottom left corner of the *Delete user window*, which appears right after we click *OK* in the *confirmation window*. 
Specify the name of the user to whom we want to transfer the files.

Click *Delete user* to finalize the process.
If we looked through the files and didn’t find them necessary, we can remove them by choosing the *Delete assets* option.

If the user didn’t have any logs/folders in his workspace, he will be deleted right after we click on *OK* in the confirmation window.

**Note:** If the user didn’t have any logs/folders in his workspace, he will be deleted right after we click on *OK* in the confirmation window.
2.8.3 Create new group

To create a new group, click on Create new group button in the Groups section.

Enter the name of the group and click on Create.

The group will be created. To add users to a group, select the group. On the right-hand side, we can select the user and click on “>” button to add the users to the group.
To remove a user from the group, select the user in *Assigned Users* section and click on “<” button.

### 2.8.4 Remove group

To remove a group, select the group and click on the *Remove group* button.
2.8.5 Assign roles to a user

To assign roles to a user, select the user and choose a role in Assigned Roles section and click on Save.

2.8.6 Add a user to a group

To add a user to a group, select the user and choose a group in the Assigned Groups section and click on Save.
3.1 Discover model

Apromore allows us to discover a process map or a BPMN model from an event log. A process map (a.k.a. directly-follows graph) is a visual representation of the log as a graph where nodes capture process activities and directed arcs between them capture sequential order relations between the activities. For example, an arc going from activity Accept order to activity Check order indicates that in the log, we can observe that process cases flow from Accept order to Check order. Process maps are a simple yet effective means to understand the basic order of relationships between process activities. As such, they are the most common type of model discovered by commercial process mining tools.

3.1.1 View process map

To view the process map, double-click on a log. Alternatively, we can select a log from the repository and click on Discover > Discover model.

A window will open up, showing the process map discovered from the log.
3.1.2 Abstraction Settings

We can adjust the complexity of the discovered map by increasing or decreasing the frequency or duration of nodes and arcs visualized in our process map. The default values for the nodes and arcs sliders are 100% and 10%, respectively.

We can abstract a process map by *Case frequency* or *Average Duration*. For example, if we abstract by case frequency and shift the arcs or nodes slider towards the left, more edges/nodes with low case frequency will be removed from the process map.

Similarly, if we abstract by *Average Duration* and shift the arcs or nodes slider towards the left, more edges/nodes with low average duration will be removed from the process map.
3.1.3 Log statistics

We can also check more detailed statistics. To inspect individual cases, use the Case Inspector. To open the Case Inspector, click on the number of cases under the Log statistics section.

The Case Inspector window will open.
Click on a specific case to visualize it exclusively in the Process Discoverer.

To check the length of the cases, click on the Activity instances column. Cases will be sorted from the shortest to the longest.
We can also sort them by pathway, using the Case variant ID column or by the Frequency of the pathway - Percentage(%) column.

To download the list of cases and their statistics, click on Download.
To inspect individual activity, use the *Activity Inspector*. To open the *Activity Inspector*, click on the number of activities under the Activities chart in *Log statics* section.

The *Activity Inspector* window will open.
To check the length of the activity, click on the Activity instances column. To check activity variant frequency, click on Percentage(%) column.

To download the list of activities and their statistics, click on Download.
To check the individual activity statistics, we can simply click on the activity. We can also select multiple activities at once by pressing *Ctrl* and dragging the mouse over the part of the model which consists of these activities.

### 3.1.4 Visualize by Frequency

We can also view the event log’s simple statistics, such as the total, median, minimum, maximum, and average number of times an activity is executed. This information is provided as a label on the activities/arcs, color of activities, and arcs’ thickness. The darker the blue color, the higher the number of times that activity has been observed in the log. The thicker arc, the higher the frequency of that arc. We can use the Frequency drop-down list in the *Visualization settings* section to view different statistics.
3.1.5 Visualize by Duration

Additionally, we can view the statistics on the time performance of the activities and arcs in the process map using the **Duration drop-down list** in the **Visualization settings** section. These are total, mean, median, minimum, maximum, and average duration of each arc (indicating the waiting time before starting a given activity, once the previous one has been completed), and total, mean, median, minimum, maximum, and average duration of each arc duration of an activity (a.k.a. the activity’s processing time). Suppose the log only has completion timestamps for each activity and not their start timestamp. In that case, these performance statistics will combine both processing time and waiting time into a single time statistics visualized on the arc. At the same time, activities will be shown as having an instantaneous duration.

Like frequency statistics, we can also visualize time performance statistics via labels on activities and arcs and via colors and line thickness (on a red scale) for activities and arcs.
### 3.1.6 Visualize by Frequency and Duration

We can also view both *Frequency* and *Duration* at the same time by clicking the [ ]. For example, if we are viewing our process map in *Frequency* mode, we can also view the *Duration* as a secondary metric by clicking on the [ ].

### 3.1.7 Visualize by Different Perspectives

Visualizing the handover between activities is not the only way a process can be analyzed. There will be times when we may be interested in assessing if a specific resource or group of resources are overloaded with work. When clicking on *Perspective* we can decide which attribute of the log will focus on the process map.

For example, to visualize the handover of work among a group of resources, we can select the *Resources* option. This option will map each actor’s organizational role in our process to a node and connect two nodes if a handover of work
occurs between the two nodes.

### 3.1.8 Filter Log

When analyzing an event log, we may be interested in isolating a particular type of behavior or removing a specific activity. An event log can be filtered by clicking on the *Filter* icon and creating a new filter that fits our needs. For more information on the optimal use of *Filter*, we suggest viewing the *Filter Log manual*.
3.1.9 View BPMN Model

Whenever the insights deriving from the analysis of a process map are not sufficient, the same functionalities are offered on top of a BPMN model. Changing the view from Process Map to BPMN model will automatically discover a BPMN model from an event log. When visualizing a BPMN model, the slider Parallelism offers the possibility to adjust the amount of parallelism (e.g., AND and OR gateways) discovered by the plugin.

3.1.10 Export Process Map/BPMN Model

A filtered log or discovered process map/BPMN can be exported by clicking on the different save buttons to export the model as a “.bpmn”, a PDF, PNG, or a JSON file.
3.1.11 Animate Log (Process Map)

The *Animate* button allows us to replay the log on top of the process map, using the *Animate a log* on top of the process map feature.

![Animate Log (Process Map)](image)

3.1.12 Search Activity

We can also search for an activity by using the search bar on the top-right.

![Search Activity](image)

For ease of view, the search results get highlighted in the process map.
3.2 Filter log

Apromore allows us to apply various filters to slice and dice an event log in different ways and focus on the filtering results. For example, we can use it to segregate specific process cases that fulfill certain conditions, e.g., all cases that transit via a particular activity or segregate two variants of the same process, e.g., the first variant containing slow cases and the second one containing fast cases.

We can access Log filtering from various places:

- In the Portal, select an event log and click on “Filter log” from the Discover menu.
- In the Performance Dashboard, click on the “Filter” menu on the top-right corner or select.
- In the Custom View of the Performance Dashboard, select Advanced and then “Filter log” from the Edit frame.
- In Process Discoverer, click on the “Filter” button from the top buttons bar, as shown below.
No matter where we invoke the filter from, the filter editor showed above will pop up.

### 3.2.1 Filter types: Case vs. Event

There are two main filter types supported by Apromore: Case Filter and Event Filter. Both filter types allow us to create a filter based on particular conditions on the cases or events.

More specifically:

- A case filter allows us to “slice” a log, i.e., to retain a subset of the process cases, e.g., those cases that contain a specific activity;
- An event filter allows us to “dice” a log, i.e., to retain a fragment of the process across multiple cases, e.g., an element containing two specific activities.

For the case and event filters, we can set several filter criteria. Let us take a look at the case filters first.
3.2.2 Case > Performance filter

To understand a process, we might want to retain or remove cases that fulfill specific performance requirements, e.g., retain all cases that complete within one month. We can use the “Performance” filter for this purpose. For example, the below screenshot captures only those cases that last no more than one month in duration.

We can decide whether to retain or remove the cases that fulfill each filter’s condition set in the filter criteria. Concerning the example above, we may determine whether to retain or remove all cases that complete in one month.

We create a filter by clicking Apply. We can observe that 80.4% of the cases fulfill this requirement.

We can use the *Arc duration* metric from the *Performance measure* drop-down menu to perform the analysis based on the duration of the path between different nodes of type activity, resource, or other event attributes.
In the example above, we decide to retain all cases where the arc duration between ER Triage and ER Registration is not more than 3.25 hours. The filter is created by clicking Apply.

In addition to the arc duration, we can also select a node duration performance metric to analyze performance by retaining or removing different nodes of type activity, resource, or different event attributes.

We can also filter out cases based on case length (number of activity instances in the case). Thus, in the example below, we retain all cases whose length is between 3 to 15 activity instances.
3.2.3 Case > Attribute filter

To retain or remove all the cases that include a specific attribute, we can use the Attribute filter. For example, we want to retain only those whose attribute Age is between 20 to 30.

For this, click on the Attribute filter. Select the age attribute from the drop-down list and tick the specific values to retain. Finally, click on Apply. In the example below, the result would be only those cases where the age attribute is between 20 to 30.

Note: For the numerical attributes only, there is an alternative to retain or remove cases by choosing the range of values using the “From”/”To” slider at the bottom of the filter window. We will see the list of values (categories) for categorical attributes like resources or product types and choose which specific values to retain or remove.

We can also retain/remove cases that include a secondary attribute.
In the given example, we retain cases where resource group L (Secondary Attribute) performs an activity ER Registration.

Note: We can also filter cases that include a specific case attribute as a primary/secondary attribute.

In addition, the Matching section allows us to set whether cases should be retained that satisfy any of the selected values (default selection) or all the selected values.

### 3.2.4 Case > Path filter

We can use the Path filter to identify bottlenecks or analyze the transitions between the activities performed. For example, click on the Path filter to retain those cases where the activity ER Registration eventually follows Release A.

We can also filter out those cases where the same resource group is performing the activities. This can be done by checking the Require checkbox and selecting Group from the drop-down list of the Path filter.
The time between the occurrence of activities can also be captured by using the Lower and Upper bound fields of the Path filter. For example, retain those cases where the time interval between ER Registration and Release A is greater than 2 hours.
3.2.5 Case > Timeframe filter

The *Timeframe* filter allows us to retain or remove those cases that are “active in”, “contained in”, “start in,” or “end in” a particular time period of the log. We can set the desired timeframe by entering the *Start* and *End* dates or using the time slider at the bottom of the Filter criteria window.

![Timeframe filter example](image)

3.2.6 Case > Rework & repetition filter

In some processes, certain activities are repeated – this can be done in direct repetitions or through the *back and forth* between two or more activities.

A *Rework* filter can be used to isolate repetitions so that only those process sequences are retained or removed that contain specific repetitions. We can also set the *Lower* and *Upper* bound for the reworked activities.

When setting multiple conditions on repeated activities, we can define whether the filter criterion should satisfy any condition or all conditions on the repeated activities.
3.2.7 Case > Case ID filter

We can choose to retain or remove cases based on a particular case ID using the Case ID filter. In the below screenshot, we are retaining those cases with case ID ‘AA’. The result would include the activities performed by the case ID ‘AJ’.
3.2.8 Case > Variant filter

We can use the Case variant filter to retain or remove the case variants based on a particular condition by entering the From variant and To variant values or using the time slider at the bottom of the Filter criteria window. For example, we want to retain up to 50 case variants to analyze the process’s most common behavior.

Let us now take a look at the filter criteria for event filters. We can use the Event filter to dice the log, i.e., isolate a specific fragment of the process across all cases. The Event filter allows us to filter by Attribute and Timeframe.

3.2.9 Event > Attribute filter

The Attribute filter of type Event allows us to retain or remove those events that satisfy the values of a specific event attribute. For example, we may want to remove those events whose activity label is “ER Registration”. This means effectively to dice the log in such a way to exclude all events related to activity “ER Registration”.

3.2. Filter log
Any attribute value can be used to set conditions. For example, in order to remove all events where the value of “DiagnosticIC” is false, we can select DiagnosticIC from the drop-down list of event attributes and then select the specific value we may want to retain or remove.

3.2.10 Event > Timeframe filter

The second type of filter criterion for events allows us to retain or remove events based on a particular timeframe. We can set the desired timeframe by entering the Start and End dates or using the time slider at the bottom of the Filter criteria window.
3.2.11 Managing filter criteria

Apromore allows us to create one filter on top of another. We can do this by clicking the Create button.

In order to edit an existing filter, select the filter and click on Edit.

We can change the sequence of the filters by using the top-down arrows on the right side. In order to delete a single filter, click on button. Alternatively, to delete all the filters at once click the last button - .
To open a saved filter click on *Open* button.

**Note:** In the filter window, a red exclamation mark next to the filter name means that another user has made changes to the filter. Click on it to save/discard changes.

We can make changes to an existing filter and then click on *Save* to save it.
The *Save as* button is used to save a new filter.

We can also upload a filter by clicking on the *Upload* button. Select the filter (.json file format) from the file explorer.
A filter can also be downloaded using the *Download* button.

We can edit the name of the filter before downloading it.
3.2.12 Undo/Redo filters

The application of filters can be applied and removed by using the *Undo/Redo* buttons. To undo a filter criterion, click on *Undo filter.*

To reapply the previous filter, click on *Redo.*
### 3.2.13 Clear all filters

To clear all the applied filters, click on the *Clear all filters* button.

### 3.2.14 Shortcuts

**Note:**

- Right-click on an arc: remove all cases containing the selected directly-follows relation
- Shift + right-click on arc: filter cases based on this arc’s duration (from any perspective)
- CTRL + Right-click on an arc: retain only cases containing the selected directly-follows relation
- Right-click on a node: remove all cases with an event containing the selected attribute
• CTRL + Right-click on a node: retain only cases with an event containing the selected attribute
• Alt (Option) + Right-click on a node: remove all events containing the selected attribute
• Alt (Option) + CTRL + Right-click on a node: retain only events containing the selected attribute
• Shift + right-click on a node: filter cases based on this node’s duration (from any perspective)
• Shift + CTRL+ right-click on a node: filter cases using this node as a primary attribute.
• CTRL + Z: Undo
• CTRL + Y: Redo

3.3 Save filter

Apromore provides the functionality of saving and sharing filters. To save a filter we first need to create a new filter and then save the filter.

To create a new filter, choose the type of filter and click on OK.

3.3.1 Save as

Once a filter is created, click Save as in order to save the new filter.
Once the filter is saved, we can see a confirmation message.
3.3.2 Load

To load filters associated to a log, click on *Open* button.

We select a filter that we wish to load and click *Apply*.  

---

3.3. Save filter
Once the filter is loaded, click on **OK** to filter the event log.
3.3.3 Save

We can update an existing filter and save it. For example, we add an additional filter criterion to an existing filter and click on `Save`.

We can see a confirmation message that the filter for the associated log is updated.
4.1 Animate logs (Process map)

Apromore allows us to replay an event log on top of its process map. To use this plugin, select an event log from the repository and click the *Animate* button in the process discoverer.

The process map within Editor along with the timeline is displayed.
Note: Once the animation button is clicked, other functionalities like abstraction and visualization settings are disabled.
4.1.1 Standard Controls

The animation will start by hitting the Play button. Each token represents the progress of a particular process instance, i.e., a case.

Standard controls are available to play, pause, fast or slow forward/rewind the animation and to skip through the end/beginning. The replay speed can be changed with the vertical bar. These actions are also available during the animation. If the view on the process map is zoomed in/out, or the process map layout is changed, the tool will try to adapt the animation to the new position of the elements on the canvas.

Tip: To zoom-in/zoom-out, press Ctrl and use the mouse scroll wheel

We can change the color of tokens by clicking on the pie chart.
**Note:** We can either choose from the default colors or add the customized ones. To add a customized color - enter a color code or drag the mouse over the palette.

To check log-related statistics, hover over the *pie chart*.

### 4.1.2 Token Traversal

A token traversing an activity indicates that the case captured by that token is performing that activity. However, if the token goes around an activity’s border, this indicates that the particular activity is skipped in that process case.

A token of a larger size or a large number of tokens slowly traversing a given path may indicate a performance bottleneck, e.g. cases pile up in a particular point of the process due to resources unavailability.
4.2 Animate logs (BPMN model)

Apromore allows us to animate one or more event logs to be replayed on top of a BPMN model. When using multiple logs, these could capture different variants of the same business process, while the process model would represent a normative specification of how things should be performed within an organization.

We can select one or more logs and one BPMN model from the repository, and click Analyze > Animate logs. In case we want to animate a single event log on top of a BPMN model, we can also switch the view from Process Map to BPMN Model in the Process Discoverer and click the Animate button.

A window will open up showing the BPMN model along with the timeline.
4.2.1 Standard Controls

The animation will start by clicking on the *Play* button. Each token represents the progress of a particular process instance (a case), with the token’s color encoding the log the case comes from.

Standard controls are available to play, pause, fast or slow forward/rewind the animation and to skip through the end/beginning. The replay speed can be changed with the vertical bar. These actions are also available during the animation. If the view on the model is zoomed in/out, or the model layout is changed, the tool will try to adapt the animation to the new position of the elements on the canvas.

**Tip:** To zoom-in/zoom-out, press *Ctrl* and use the mouse scroll wheel.

We can change the color of tokens of a specific log by clicking on the *pie chart* next to the needed log name.
Note: We can either choose from the default colors or add the customized ones. To add a customized color - enter a color code or drag the mouse over the palette.

To check log-related statistics, hover over the *pie chart* next to the needed log name.
4.2.2 Token Traversal

A token traversing an activity indicates that the case captured by that token is performing that activity. However, if the token goes around an activity’s border, this indicates that the particular activity is skipped in that process case.

A large number of tokens slowly traversing a given path may indicate a performance bottleneck, e.g. cases pile up in a particular point of the process due to resources unavailability.

For visualization purpose, we can hide and show individual/multiple log tokens by unchecking/checking the checkbox below the pie chart.
4.3 View dashboards

Apromore’s Custom Performance Dashboard allows users to analyze a business process from a performance measurement perspective visually. The Performance Dashboard displays a variety of aggregate statistics and charts. The Performance Dashboard plugin allows us to analyze one process in isolation or to compare multiple process variants. For example, we can use the Performance Dashboard plugin to compare how a given process is executed across multiple regions or compare the variant of a process consisting of slow cases versus faster cases.

To open the dashboard plugin, select at least one event log and click on Analyze -> View performance dashboard. To compare multiple process variants, we need to select multiple event logs and then open the Performance Dashboard plugin.

The customizable performance dashboard consists of three default views: Overview, Activities, and Resources. All the dashboards include statistic tiles, charts, and tables.
4.3.1 Overview

The overview section’s stat tiles consist of the event log’s performance measures like the number of activity instances, active cases over time, case variants, case duration, and log timeframe. Four main charts are presented in the overview dashboard: Events over time, Active cases over time, Case variants, and Case utilization.
4.3.2 Case Inspector

The case inspector displays a full list of cases and case variants for the selected event log, together with their corresponding statistics.

We can click on a given case in the Case Inspector to get further details about the activities performed in this case.
4.3.3 Activities

The activities dashboard includes the activities, average activity frequency, and average activity duration statistic tiles. It also includes different charts of various activity performance metrics such as case frequency, min/max duration, min frequency per case, et cetera.

4.3.4 Resources

The resources dashboard includes all the resource performance metrics like case frequency, total frequency, average duration, min duration, and max duration.

While viewing/editing a shared dashboard, we may receive an update notification stating that the dashboard is modified. We can choose to save/discard changes and click on Apply.
4.4 Create dashboards

The Apromore Custom Performance Dashboard offers a variety of custom visualization options.

To open the dashboard, select at least one event log and click on Analyze” -> “View performance dashboard. We can also visualize multiple event logs in the custom dashboard by selecting them.

Once the performance dashboard opens up, click on the ‘+’ button to create a dashboard from an existing dashboard, or create a dashboard from scratch.
4.4.1 Create from existing views

The main purpose of creating a dashboard from an existing view is to modify an existing view by retaining the existing performance metrics and adding additional performance metrics.

To create a custom dashboard from an existing view, click on *Create from existing*.

We can choose from three different views: Overview, Activities and Resources.
To create a new dashboard from an existing resources view, click on Resources.

A new Resources dashboard will open up. Similarly, we can create a new dashboard from Overview and Activities.
4.4.2 Create from scratch

To create a custom dashboard from scratch, click on *Create from scratch*.

A blank editable view will open up.
We can change the view’s title by entering the text in the Title text field.

4.4.3 Add Stat Tiles

We can also add different statistic metrics by clicking on the Add a new tile button.
We can select different metrics from the *Stats type* drop-down list and make changes to different visualization metrics.

We can also change the colors of a value or an icon by clicking on the color box.
We can also add and save a custom color by adding the Hex code of the desired color.
4.4.4 Add charts

To add a chart, click on the *Add new chart* button.

To make changes to a chart, make sure the chart is selected first from the *Chart type* dropdown.

We can add different types of charts to the dashboard. To know more about different charts, please check the manual.
4.4.5 Add Tables

To add a table, click on the *Add new table* button.

We can select different tables from the *Table type* dropdown.
After all the changes have been made, click on **Done**.

### 4.5 Add charts to dashboard

Apromore’s Performance Dashboard allows users to analyze a business process from a performance measurement perspective visually. The Performance Dashboard displays a variety of aggregate statistics and charts. The *Performance Dashboard plugin* allows us to analyze one process in isolation or to compare multiple process variants. For example, we can use the *Performance Dashboard plugin* to compare how a given process is executed across multiple regions or compare the variant of a process consisting of slow cases versus faster cases.

To open the dashboard plugin, select at least one event log and click on **Analyze** \(\rightarrow\) **View performance dashboard**. To compare multiple process variants, we need to select multiple event logs and then open the Performance Dashboard plugin.
4.5.1 Activity instances over time chart

We can add different charts by clicking on the *Add a new chart* button.

The *Activity instances over time chart* displays how many activity instances occur during the time frame of the entire event log. The Y-axis denotes the ‘Timestamp’ of the entire log. The X-axis denotes the number of activity instances. This chart can help us to identify various patterns, such as the periodicity of the process. We can observe, for example, that in certain months of the year or certain days of the week, there is more activity than in others.
4.5.2 Active cases over time chart

The Active cases over time chart displays the work-in-progress over the entire timeframe of the log. To understand and view the work-in-progress over a period of time, click the Active cases over time tab. Alternatively, we can use Case length filter.

4.5.3 Case variants chart

A case variant is a sequence of activities followed by one or more cases, i.e., a distinct pathway. For example, if A, B, C, and D represent activities, then ABCD, ACBD, and ABC represent three case variants. Typically, there are multiple cases in a log that follow the same case variant. For example, it may be that 10 cases follow the case variant ABCD, while 5 cases follow the case variant ACBD. The Case variants chart displays the number of cases that follow each variant. The variants are sorted from most frequent to least frequent.
4.5.4 Activity instances per case chart

The Activity instances per case chart displays the number of activity instances in each case. The horizontal axis depicts the number of activity instances, while the vertical axis depicts the number of cases.

4.5.5 Case duration chart

To visualize the histogram of the case duration of the process, click on the Case Duration tab. Based on the screenshot below, we can identify many cases between the start time and approximately 23 days. However, some cases took more than a month.
4.5.6 Case Utilization

The Case utilization is the ratio between the processing time of a case and the case duration. The processing time of a case is the amount of time during which someone was actively working on an activity in the case (i.e., the case duration excluding waiting times). The “Case utilization” chart displays the histogram of case utilizations in the log. Each bar in the chart shows the number of cases (Y-axis) with a given case utilization (X-axis). If we see one bar only, there may be two reasons: either all cases have the same value of case utilization, or the other bars are tiny. If that is the case, press the “Log scale” button on the chart’s top left corner to make the other bars visible.

4.5.7 Processing time chart

The processing time of a case is the amount of time during which someone was actively working on an activity in the case (i.e., the case duration excluding idle times). We can choose between the total, maximum, and average processing time from the dropdown menu. The Processing time chart displays the histogram of processing times of the cases in the log. Each bar in the chart shows the number of cases (Y-axis) with a given processing time (X-axis). If we see one bar only, there may be two reasons: either all cases have the same value of processing time, or the other bars are tiny. If that is the case, press the Log scale button on the chart’s top left corner to make the other bars visible.
4.5.8 Waiting time chart

The waiting time of a case is the amount of time during which nobody was actively working on an activity in the case. We can choose between the total, maximum, and average waiting time from the dropdown menu. The Waiting Time chart displays the histogram of waiting times of the cases in the log. Each bar in the chart shows the number of cases (Y-axis) with a given waiting time (X-axis). If we see one bar only, there may be two reasons: either all cases have the same value of waiting time, or the other bars are tiny. If that is the case, press the Log scale button on the chart’s top left corner to make the other bars visible.

We can create different types of charts using the custom dashboard. Charts like column and pie charts work best with categorical values, while line charts work best with numerical data.
4.6 Save dashboard

Apromore allows us to choose whether or not to auto-save changes to a dashboard.

4.6.1 Save a dashboard

Select a log and click on View performance dashboard.
To auto-save a file, click on the Save dashboard button.

To enable/disable the auto-save option, click on the tick-box.
Note: The auto-save option is enabled by default

The auto-save option is triggered when we:

- Click on Done after editing a dashboard view.
- Click on Apply after making changes to the style of the dashboard.
- Click on OK after applying a filter to the dashboard.

4.6.2 Open a saved dashboard

To open a saved dashboard, select a log and click on View performance dashboard.

The View performance dashboard window appears if the log have any saved dashboards associated with it.
To open a saved dashboard, select it and click on *Open*.
4.7 Additional dashboard functionality

4.7.1 Advanced View – Slice & Filter

The Advanced view allows us to slice and filter the logs. To slice a log click on the button next to the Slice Log.

4.7.2 Advanced > Slice

We can slice a log based on Event attribute, Case attribute, Timeframe or Performance. In case of Event attribute select the events with which you want to slice the log.

After clicking on OK, we can see the details of the selection we made.
Click on Apply, to see the results.
Similarly, we can either slice by Case attribute, Performance or Timeframe.

In case of Timeframe and Performance there is an option of Add slice line. For this click on the button next to Add slice line and slide the slider. Alternatively, you can also select a date from the date picker.
4.7.3 Advanced > Filter

We can add a filter by clicking on the button next to Filter log.

Select the desired filter and click on Ok. For optimal use of filters, please go through the Filter Log manual.

Filter Log window appears. Click OK to complete filter setting.
To apply the filter click on *Apply* in the Slicing and Filtering section.

**Note:** While slicing/filtering log, we may get a warning sign stating if there is a problem. Hover over to see the details.
4.7.4 Add Reference Lines

For visualization purpose, we can also add reference lines to a chart to mark important timelines. For this click on the button in the Reference lines section.
4.7.5 Add KPI

We can add KPI target from the KPI thresholds section, which is available in the Basic view.

The Mean + Tolerance metric allows us to specify a mean performance metric with a specific tolerance (in percentage).

The Custom metric allows us to specify custom performance indicators.
4.7.6 Compare Multiple Process Variants

Custom Performance dashboard not only helps us to dive into the statistical metrics of a single event log but also helps us to compare different versions of an event log. For this, select more than one version of the same event log and click on Analyze -> View performance dashboard.

We see the charts of both the logs combined.
4.7.7 Split Charts

We can also choose to split charts to compare multiple process variants.
4.7.8 Zoom-in/Zoom-out

We can zoom into the graph by simply dragging the mouse over the part of the chart we would like to zoom.

We can zoom out of the graph by clicking on *Reset Zoom* button.
4.7.9 Add filter

To add a filter, click on the drop-down button next to the log name. Filter log window appears. Select the desired filter and click on Ok. For optimal use of filters, please go through the Filter Log manual.

Create a filter and click on OK.
4.7.10 Export/Download Chart

We can also print or download a chart to a PNG, JPEG, PDF, SVG vector, CSV and XLS file.
4.7.11 Clone Chart

To add the same chart again, click *Edit view*, select the chart and click on *Clone content*.

4.7.12 Organize Charts

In case of multiple charts/stats, we can re-arrange it by clicking on the button and simply moving the charts/stats by drag-and-drop method. Click the move button once to move a selected block. Click the move button twice to move all the blocks.
4.7.13 Remove Chart/Tile/Table

In order to remove a chart/table/block, select a chart and click on 

![Screenshot of a dashboard with a chart and options for removing charts.]

4.7.14 Copy Format

To copy the formatting settings used in one block to another block, select a chart/tile/table and click on the button.

![Screenshot of a dashboard with options for copying formatting.]

Click on the button once to copy the formatting from one block to another. Double click to paste to multiple blocks. We can see the style of the block to be copied. Click on another block to paste the formatting settings.

4.7. Additional dashboard functionality 169
4.7.15 Copy Settings

To copy the filter and slicing rules from one block to another, select the block and click on the button.

Click on the button once to copy the settings from one block to another. Double click to paste to multiple blocks. We can see the slicing and filtering rules of the block to be copied. Click on another block to paste the settings.
4.7.16 Edit Dashboard

To edit the new a dashboard click on the button.

4.7.17 Download Dashboard

To download the current view of the dashboard, click on the *Download data of current view in CSV* button.

We can select from a wide range of encoding options to download the dashboard into a CSV file.
Select the appropriate option and Click on Download.

The file will be downloaded as a zip file and contain all the performance metrics charts/tiles/tables.
4.7.18 Set Dashboard as “Home”

For ease of access, we can set a dashboard as *Home* by clicking on the 🏡 button.

4.7.19 Change style of dashboard

To change the style of the dashboard, click on the 🎨 button and select from different styling options.
4.7.20 Change Scale

The scale can also be changed to *Logarithmic* and *Relative* from *Y-Axis scale*.

4.7.21 Reset Views

In case of dashboards created from existing views or changes made to an existing default view (Overview, Resources, Activities), we can choose to reset view of the dashboard by clicking on the button. We can choose to reset the current view or all the views.
4.8 Simulate process

Apromore allows users to simulate .bpmn models to understand how the business process will look and work in different scenarios.

We can do the simulation of process models in Apromore by performing two steps:

- Specification of simulation parameters
- Creation of simulated log

Double-click the BPMN model to open it.

A window will open up, showing the selected BPMN model.
4.8.1 Specification of simulation parameters

To specify simulation parameters, click on the *Toggle simulation parameters panel* button.

The simulation panel with different parameters to be specified will appear from the BPMN editor window’s right side.

**Note:** If we want to hide the parameters panel, we can always click on the “>>” sign located at the right side of the panel and click on it once again to make it visible.
The parameters are organized into different tabs. For convenience, it is recommended to fill it in the following order: **General** -> **Timetables** -> **Resources** -> **Tasks** -> **Gateways**.

**Note:** We can’t proceed without the specification of the mandatory parameters. These are marked red.
4.8.2 General parameters tab

The inter-arrival time is the time between each arrival of the process instances. It shows how frequently a new process instance starts.

Apromore offers a variety of options for inter-arrival time, as shown below.

The value denotes the inter-arrival time unit. In the following example, the inter-arrival time is fixed and equals 5 hours, meaning that a new process instance starts every 5 hours.

The total number of process instances shows how many BPMN process instances start in the simulation scenario.
Note: For preventing us from entering incorrect values, Apromore displays inline alert messages signaling that we need to recheck the data.

We can specify the simulated scenario start date and time to determine when the first process starts.
We can exclude a certain percentage of statistics from the start and the end of the process instances that fall between the start and the end time of the simulation scenario. This is usually done, considering the availability of resources and activities that are handled without any delays.

For the cost calculations, we may choose a suitable currency from the drop-down list.
4.8.3 Timetables, Resources and Tasks parameters tabs

After we finished entering the general tab information, we then switch to the Timetables tab.

While adding the new timetable, it is required to name it and specify the working timeslot.
Note: One timetable may consist of many different timeslots. This is very useful when workers (also known as actors/resources) work in shifts.

In the example below, workers who follow “Timeslot 3” from “Timetable-1” work five days (Monday-Friday) from 8.00 till 17.00.

In the “Resources” tab, the default resource is created automatically.
To add the new resource, select it from the list and press “+”. To delete it, select and then press “x”.

Specify all the resource details required in the new resource window, which loads right after clicking on “+”.

4.8. Simulate process
Number of Resources is the amount of the new resource type actors participating in this scenario. Cost per hour is the amount the resource earns per hour working.

A timetable is assigned to a resource from the Resource timetable drop-down list.

After we finished entering the information in the Resources tab, we then switch to the Tasks tab.
Click on a task in the BPMN model in order to set the simulation parameters for the task. The simulation parameters of a task are:

- The resource pool responsible for performing this task
- The probability distribution of the task duration and the parameters of this distribution (e.g., the mean in the case of an exponential distribution). The duration of the task is the time it takes for a resource to execute one instance of a task. Please note that the duration of a task must not include the waiting time before the start of the task. It should only include the processing time.

Note: For a model to be simulated, the tasks must be untyped (Abstract). Apromore does not currently support the simulation of process models where some of the tasks have a type such as User task, Service task, etc.

We can use an alternative approach for more complex models by just clicking on the task we would like to change.
The task details window will open automatically.

4.8.4 Gateways

Gateways is a BPMN notation used to control how a process flows. Gateways can be exclusive (XOR), meaning that precisely one alternative path can be selected or inclusive (OR), meaning that there can be several paths.

All gateway elements in the BPMN model require execution probabilities for their outgoing sequence flows.
Note: The sum of the probabilities for the execution of each gateway must be 100%.

After we entered the simulation parameters, we can save the model.
When the save dialog appears, click *OK*.

To simulate the saved model, go to the main workspace -> *Analyze* -> *Simulate model*. 

188 Chapter 4. Analysis
To save the simulated log, click on **Save**.

The simulated log appears in the workspace.
Note: Suppose, for some reason (for instance, the model was quite complex with the variety of tasks and many resources), we ignored the mandatory data lines and didn’t specify them before. In that case, Apromore will display the list of errors to correct them.

We can view a range of statistics for simulated logs, including case duration, case duration within timetable, case waiting time, cycle time, waiting time, and cost in dashboards.
In addition to this, we can simulate two what-if scenarios. We can then compare the simulated logs by animating 2 logs against the BPMN model by going to the main workspace, selecting 2 logs and BPMN model -> Analyze -> Simulate model.

A window will open up, showing the simulation overview.
Chapter 4. Analysis
5.1 Search similar models

Apromore allows us to search similar models.

Select a BPMN model and click on Redesign -> Search similar models.

A window will pop up displaying various metrics. For example, the Label sim. threshold provides the similarity threshold of the different labels of a model. Initially, each field includes the default values. We can also choose to search the latest versions or all of the versions.
Click on *OK*. The results will contain similar models along with the similarity score.

### 5.2 Merge models

Apromore allows us to merge models and animate a log on top of the merged models.

In order to merge a model, select two models and click on *Redesign -> Merge Models*. 
A window will pop up which will allow us to name the merged model. Enter the name and click on OK.

The merged model will now appear in the repository.
We can view the merged model in the BPMN editor.
6.1 Train predictive models

The Training plugin allows users to generate predictive models for different types of predictions. Specifically, it is able to predict generic process properties, such as remaining time until case completion, the next most likely activity to be executed and whether a case will take longer than a user-defined time threshold. Additionally, the tool can build models to predict log-specific case properties, for example, the total application cost in an insurance claims handling process.

Before importing your log into Apromore, it needs to be pre-processed to add all the required attributes. The tutorial here describes a minimalist example of pre-processing operations for an event log. For demonstration purposes, Apromore repository provides several pre-processed logs under Examples/Predictive Monitoring folder. These logs can also be downloaded from here.

• To use the plugin, select a training log from the repository and click on Monitor -> Train predictor with log.

- As a minimum input, a user only needs to select a prediction target, i.e. an indicator to be predicted.
• Experienced users may switch to the advanced mode to fine-tune training configuration and even train multiple models at once.

• Once the necessary models have been built, the tool assesses their accuracy with respect to multiple evaluation metrics using a held-out validation set.
• Trained models are saved in the Apromore database and can be pushed to the *Runtime component* to make predictions for ongoing cases and visualize them in an operational dashboard. A screencast of this plugin can be found here. For non-Apromore users, a stand-alone version of the plugin can be accessed at training.nirdizati.org.

### 6.2 Open predictive dashboard

**Note:** Apromore’s predictive monitoring plugins are available as add-ons to Apromore Enterprise Edition.

Once the predictive models have been trained, they can be deployed to the Runtime predictive monitoring environment of Apromore, to make predictions on ongoing cases. The Runtime plugin bundle can be used to stream an event log from the repository, or hook into an external stream. Either way, the input stream is transformed into a stream of predictions which is visualized in a Web-based dashboard.

To use the plugin, select an event log from the repository and click on *Monitor* -> *Predictively monitor log*. For demonstration purposes, Apromore repository provides several pre-processed logs under Examples/Predictive Monitoring folder. These logs can also be downloaded from here.
Create a new Predictive Monitor.

Select the created monitor and click *Stream log to dataflow*. 
Click *Show dashboard* to start streaming events from the log. A dashboard will show up and populate with ongoing cases:

The dashboard provides a list of currently ongoing as well as completed cases. For each case, it is also possible to visualize a range of summary statistics including the number of events in the case, its starting time and the time when the latest event in the case has occurred. For the ongoing cases, the Runtime plugin bundle provides the predicted values of the performance indicators the user wants to predict. For completed cases, instead, it shows the actual values of the indicators. Color-coding is applied to help users quickly nail down potentially problematic cases.
6.2.1 Export performance predictions into CSV

In addition to the dashboard for continuous real-time process monitoring, the Runtime plugin supports a *regular reports* use case where users can get reports in a CSV format on a regular basis with the current set of predictions. These reports can be readily imported into common data analytics platforms (e.g. Microsoft Excel, Tableau, QlikView, R) for further exploration and visualization.

A screencast of this plugin can be found [here](#).
7.1 Version 8.0

Release Date: November, 2021

7.1.1 Feature/Enhancement

Custom Calendars

- Apromore now provides the ability to create and edit custom calendars and to associate a custom calendar with an event log. When creating a calendar, you can include public holidays based on your location and add custom holidays to the calendar.

Delta Analysis between process models

- Apromore now allows you to compare two BPMN process models to perform delta analysis. For example, you can use delta analysis to compare a process model discovered from an event log (capturing the as-is process) with a reference process model (capturing a to-be process). When you compare two process models using delta analysis, the tool displays the differences and allows you to overlay the differences on top of the process models.

Filter and Dashboard Templates

- Apromore now provides the ability to save a filter or a dashboard template that you have defined on an event log, and to apply the saved template to another log. For example, you can create a dashboard template on an event log containing all the cases of an order-to-cash process that completed in October, and then copy it to an event log containing all the cases of the same order-to-cash process for the month of November.

Internationalization

- Apromore now provides the option to switch between different languages. Currently, we support English and Japanese, with German coming soon. New languages can easily be added.

Support for Group Authorization

- Apromore now supports group-based authorization using groups extracted from an external identity provider (SAML or LDAP).

Anonymization

- You can now choose to anonymize one or more columns during log import by selecting the “anonymization” icon on the columns you wish to anonymize. For example, you may anonymize sensitive information such as case IDs and resource names.

Automatic data ingestion via the S3 connector
• You can now ingest data into Apromore via our AWS S3 Connector. The logs can be pushed into S3 buckets via
data ingestion pipelines, and picked up automatically by Apromore to be registered in Apromore’s repository. The S3 bucket can be hosted by Apromore or the customer, in their private AWS cloud. Encryption can be managed by AWS with customer-provided master key, or directly by the customer.

Case and Event attribute on X and Y-axis
• We have added more customization options to Apromore’s Dashboard. You can now display numerical or
categorical case/event attributes on the X and Y-axis of any chart in a dashboard. For example, you can create
a chart to display the number of resources (Y-axis) who perform each activity in the log (X-axis). If you select
a numeric attribute in the Y-axis, you can also select an aggregation function such as average, total, median,
etc. For example, you can create a chart that displays the countries on the X-axis and for each country, the total
revenue on the Y-axis.

KPI Thresholds and Reference lines
• In the Dashboard, you can now set KPI thresholds and add reference lines for average and median, as well as
custom reference lines, along both X and Y-axis. For example, you can choose to add a KPI threshold to separate
the cases with a higher waiting time from those with a lower waiting time, or show the average number of active
cases over time in the Work-in-Progress area chart.

Exporting Dashboard Analytics to S3 buckets
• Apromore now provides the capability to export dashboard analytics as CSV or Parquet files and save these
locally or on an AWS S3 bucket.

Between Filter
• With a couple of clicks, you can now define a new filter criterion to retain or remove events between the first or
last occurrence of a source and target node in the process map. For example, you can retain all events between
the first occurrence of the “Send invoice” activity and the last occurrence of the “Receive payment” activity.

Save and edit ETL data pipelines
• Apromore now supports the ability to save and edit data ingestion pipelines. For example, you can now edit an
existing pipeline by replacing the existing logs with an event log with the latest data.

Performance Improvement in Dashboard
• The performance of the operations performed on large logs in the dashboard has been improved.

Case Variant Inspector
• You can now inspect each case variant individually using the case variant inspector in the Process Discoverer
plugin, and check out the value of attributes for each node in the variant.

7.1.2 Improvements and Bug Fixes

• Improvement: The start and end timestamps were exported in a single column when exporting an event log in
CSV format. Now, both timestamps are placed in separate columns within the same row.

• Improvement: You can now choose to tag a column as a Perspective in the Log Importer. Once done, you can
switch between these perspectives in Process Discoverer.

• Improvement: The Log Importer now supports ISO-8859-1 (Latin-1) encoding type.

• Improvement: An event log with a standard ISO-8601 format timestamp can now be imported into Apromore.

• Improvement: The ETL plugin now supports the ability to subtract two timestamps and trim a column value.

• Improvement: You can now upload zipped BPMN models

• Improvement: You can now set the name of the log when importing it into Apromore
- **Improvement**: A BPMN model shared with a viewer cannot be exported/modified.
- **Fix**: A log containing a case ID greater than 15 digits could not be uploaded.
- **Fix**: The labels on gateways in a BPMN model were not getting updated when changing them.
- **Fix**: Uploading files in Apromore using the ETL plugin used to throw an error when connecting to an S3 bucket with a name greater than 30 characters.

## 7.2 Version 7.20

*Release Date: June, 2021*

### 7.2.1 Feature/Enhancement

**Extract-Transform-Load (ETL) Console**

- Apromore now comes with a graphical ETL console that allows you to compose event logs from one or more tables or data sources. The ETL console allows you to define data pipelines to extract tables from relational databases, transform these tables to compose an event log, and load the resulting event log table into Apromore. In addition to different join operations, you can remove columns and create columns in the event log by composing existing columns using arithmetic, concatenation, and find-and-replace operations. For example, you can add a “Cost” column to an event log and compute this cost based on the hourly rate of your resources and the duration of tasks. You can also schedule a data pipeline to run hourly, daily, weekly, or monthly jobs to extract, transform, and load event logs into Apromore.

**Single Sign-on Support**

- Apromore can now be connected with your corporate identity system for single sign-on (SAML or OpenID).

**Storage in Amazon S3 buckets**

- Apromore now comes with an option to store your event logs in a dedicated Amazon S3 bucket for high reliability and security (available for enterprise licenses only). Your IT security team can be given rights to audit your tenancy’s S3 bucket. The data in your tenancy’s S3 bucket is protected at all times using either an Amazon S3-managed encryption key or an encryption key provided by your IT team. This enables your IT team to have full control over access to your event logs.

**Transfer Ownership**

- Before deleting a user, you can transfer ownership of all the assets (models, logs, analytics artifacts) to better manage business continuity.

**Fine-Grained Sharing**

- You can choose to share individual dashboards and filters associated with a log by giving a user restricted viewer rights. For example, when sharing an event log, you can choose which specific dashboards or filters you wish to share, as an alternative to sharing all the associated dashboards and filters.

**Case Length Filter**

- You can now filter out cases based on case length (number of activity instances in the case). For example, you can retain or remove all cases whose length is between 3 to 15 activity instances.

**Undo/Redo Filter**

- You can remove/reinstate a filter criterion using the undo/redo filter buttons in Process Discover.

**Performance Improvements in Filter**
• The performance of the filter operations on large logs has been improved.

Look-and-feel improvements in Log Animator
• The ability to hide/unhide tokens of a log in a multi-log animation has been introduced. You can also customize the color of the tokens.

Report Issue
• A Report Issue button has been introduced to allow users to report bugs.

Recursive Folder Sharing
• You can now share a folder in such a way that all sub-folders and files inside that folder are shared along, recursively.

7.2.2 Improvements and Bug Fixes

• Improvement: When trying to animate a syntactically incorrect process model, the log importer now shows user-friendly error messages.

• Improvement: You can now animate both process maps and BPMN models directly inside Process Discoverer.

• Improvement: File names can now contain commas and periods.

• Improvement: A new “Generate report” function in the dashboard allows you to choose which tiles, charts, and tables you wish to include in the Word, PDF or Powerpoint report (or you can select “all” to include everything).

• Fix: The BPMN editor gives an error message when you change the version number to a different format.

• Fix: The shortcut for opening the arc duration filter is not working.

• Fix: In the slice log window, the number of cases is incorrect.

• Fix: Column names with accented letters are not displayed in the log importer.

• Fix: When a logs contains empty column names, no data is shown in the log importer.

• Fix: Access rights management window gives an error when the group name matches the user name.

• Fix: The fields in the user creation window are not validated.

• Fix: Incorrect error message is given when a file name contains more than 60 characters.

7.3 Version 7.19

Release Date: January, 2021

7.3.1 Feature/Enhancement

Process Simulator
• You can now attach a simulation scenario to a BPMN model and simulate a model with an attached simulation scenario. The output of a simulation is a simulated log. You can analyze a simulated log using all the functionality available in Apromore (Process Discoverer, Dashboard, etc.). In the Dashboard, you can view a range of statistics for simulated logs, including case duration, case duration within timetable, case waiting time, cycle time, waiting time, and cost.

Node duration performance filter
• You can filter out cases based on the node’s duration.
Arc duration performance filter
• You can filter out cases based on the arc’s duration.

Secondary attribute filter
• You can filter out cases based on two attributes simultaneously, for example, retain or remove all cases where there is an event with Activity = “Create order” (primary attribute) and Resource = “John Smith” (secondary attribute).

Share filters and dashboards
• Multiple users can edit filters and dashboards concurrently.

Dashboard auto-saving
• You can now choose whether or not to auto-save changes to your dashboards.

Export dashboards
• You can now export your dashboards in a variety of formats incl. Word and PowerPoint to create professionally looking reports.

Timestamp format detection in CSV Importer
• A wider range of timestamp formats are now supported.

Timezone detection in CSV Importer
• When you import a CSV/XLSX/Parquet file, the timezone is automatically detected.

Import Parquet and XLSX files
• You can upload a parquet or XLSX file.

Performance and look-and-feel improvements in Log Animator
• The responsiveness of the log animator has been improved. When a large number of tokens are stuck in the same arc, a bubble is shown instead of showing individual tokens.

7.4 Version 7.18

Release Date: October, 2020

7.4.1 Feature/Enhancement

Portal grid view
• You can browse through the folders and files in Apromore’s Portal in grid format (default mode) in addition to the old list format.

Import log from URL
• You can import a file from Dropbox, Google Drive, Microsoft OneDrive or from any URL.
• See: Upload a file from URL

Save and share filters
• You can save filters associated with a log and share these filters alongside the event log.
• Note: Only the owner of an event log can save, edit, or remove the filters associated with that log. Other users can define temporary filters but not save them.
Customize, save & share performance dashboards

- You can add, remove, or customize any performance indicator, chart or table in the default views of the performance dashboard.
- You can add one or more custom views to the performance dashboard of a log. Custom views can be created from existing views or from scratch.
- You can save and share dashboards. All changes you make to a performance dashboard are saved together with the event log and are visible to all users who have access to the log.
- See: Video demonstration of the new Performance Dashboard.
- Note: Only the owner of a log can edit the performance dashboard of the log. Other users can make a copy of a log and customize the dashboard on a copy of the log

Reusing CSV import schemas

- When you import a CSV file, the mapping of the columns (schema mapping) is automatically saved. When you later import a CSV file with the same column headers, the CSV importer prompts a dialog box to let you choose whether to apply the saved mapping or not.

Clear applied filters

- You can clear all the filters on the current log in Process Discoverer with a single click.

Search box in Process Discoverer

- A new search box in Process Discoverer allows you to search for a node (e.g. activity) by its name or a prefix of the name. All nodes that match the search string are highlighted.

Enhanced users and groups management

- You can grant access rights to any folder and file you own either to an individual user or to a group.
- Administrators can create groups and assign users to groups.
- See: Users and groups management

Download process performance stats from dashboard

- You can download the data behind any chart or table in the performance dashboard in CSV format, or you can download all CSV files with the data in the performance dashboard in a single zip file

Copying and moving logs or process models

- You can copy or move files across the folders in the Portal via the copy, cut, and paste icons.

Improved session management

- We have made improvements to session management to improve performance and reduce session timeouts.

LDAP Authentication

- System administrators can more easily configure Apromore to connect to a corporate LDAP directory for authentication.

New shortcuts for filtering

- You can open the case filter, case variant filter, event filter, activity filter, performance and timeframe filters in one click from the Process Discoverer by clicking on the respective icons in the Log Statistics and Temporal statistics sections of the Process Discoverer.

Relative case frequency overlay

- You can now display the relative case frequency on each node/arc in the Process Discoverer. The relative case frequency is the percentage of cases in which a given node or directly-follows relation occurs.
7.4.2 Bug Fix

Folder and file renaming
• The portal gives an error message when you enter forbidden characters in file name.

Handling of long labels
• Fixed a bug that made long activity or node labels to go across the corresponding node in the process map/model.

7.5 Version 7.16

Release Date: June, 2020

• New Features:
  – Tiles of performance measures can now be created in custom dashboards. These can be useful to display a set of standard and user-defined KPIs, in addition to the custom charts
  – Aggregated log stats can now be exported from the Dashboard into CSV files
  – Reimplemented median calculations for frequencies and durations in Process Discoverer
  – Introduced “breadcrumbs” for easier Portal navigation
  – Process models and logs can now be searched for from the Search bar of the Portal

• Improvements:
  – Improved memory management across various plugins
  – Process models created by the Merge plugin are now automatically laid out
  – Improved automatic detection of various timestamp formats in CSV Importer
  – Automatic detection of case attributes and event attributes in CSV Importer
  – Removed unused fields in the Portal
  – Simplified import of process models
  – Multiple visual and performance improvements in custom dashboards

• Bug Fix:
  – Fixed issue with not being able to animate some logs
  – Fixed issue with misaligned timelines in the log animation
  – Fixed issue with CSV importer failing due to missing case identifiers or activity names
  – Fixed issue with the results of Similarity Search not being displayed until the Portal is refreshed
  – Fixed some issues with the Rework & repetition filter
### 7.6 Version 7.15

*Release Date: May, 2020*

- **Process Discoverer:** New ribbon interface makes it easier to tune and switch between visualization and abstraction settings
- **Dashboard:** Ability to create customized charts with user-defined KPIs
- **Portal:**
  - Enhanced user registration screen
  - Ability to choose file format when downloading event logs (XES or CSV, and encoding for CSV files)
- **Log Animation:** Visual improvements in the Log Animation
- **CSV Importer:** UI and performance improvements
- **Various bug fixes and performance improvements**

### 7.7 Version 7.14

*Release Date: March, 2020*

- **Process Discoverer:**
  - Re-engineered plugin with new internal, high-performing data structure
  - Re-designed user interface with new abstraction functionality and statistics visualization
- **Filter:**
  - Cosmetic improvements
  - Performance improvements
- **Dashboard:**
  - Log cloning feature
  - Cosmetic improvements
  - Performance improvements
- **Various bug fixes and performance improvements**

### 7.8 Version 7.13

*Release Date: February, 2020*

- **New modern UI featuring consistent branding and look & feel**
- **CSV Importer:**
  - Support for non UTF-8 encodings
  - Fault tolerance (e.g. missing attribute value)
- **Filter:**
– New Rework & Repetition filter makes it easier to track cases with repeated tasks (e.g. rework due to amendments)
– Ability to search for specific cases and event attributes when setting filters
– New Case variant and Case ID Inspector view

• Process Discoverer:
  – Pie charts to show the percentage of cases, variants and events left after applying a filter
  – Performance improvements

• Dashboard:
  – Distinction between Case attributes and Event attributes
  – Relative frequency in Activities and Resources views
  – Performance improvements

• Single Editor for process modeling based on BPMN.io (legacy editor deprecated)
• Various bug fixes

### 7.9 Version 7.10

*Release Date: December, 2019*

• Filter:
  – Advanced case variant filter to show the distribution of case variants
  – Advanced options for the Eventually-follows filter
  – Filtering by processing time, waiting time and case utilization when events have start timestamps
  – Advanced options for Time window filters (case contained in the time window, active in, starts in, ends in)
  – Ability to download and upload filter criteria for reuse
  – Pie charts to show the percentage of cases, variants and events left after applying a filter
  – Minor cosmetic fixes

• Dashboard:
  – Support for case-level attributes
  – Minor cosmetic fixes

• CSV Importer:
  – Improved data type detection
  – Ability to import zipped and gzipped CSV files

• Process Discoverer: Various bug fixes and improvements
• Caching mechanism to improve system performance
7.10 Version 7.8

Release Date: October, 2019

- **Filter**: Advanced filtering options
- **CSV Importer**: More robust CSV Importer
- **Improved handling of security permissions for event logs**
- **Process Discoverer**:
  - Performance and visual improvements
  - Various bug fixes

7.11 Version 7.6

Release Date: August, 2019

- **Filter**: New Filter plugin
- **Process Discoverer**: Various bug fixes and performance and visual improvements
- **CSV Importer**: More robust CSV Importer
- **Improved handling of security permissions for event logs (Security button)**
- **Migrated to the current version of ZK libraries 8.6.0.1**
- **Dynamic switching of UI themes (Account -> Change theme)**

7.12 Version 7.5

Release Date: August, 2019

- **Dashboard**: New Dashboard plugin
- **Process Discoverer**:
  - Automatic centering and fit to screen when changing layout
  - Various bug fixes and performance improvements
- **CSV Importer**:
  - Improved tolerance for errors while importing CSVs
  - More robust mechanism to recognize timestamp format
  - Multiple UI improvements
- **Added password recovery feature**